Subscribe (again)!

10
February 3, 2018 // miscellaneous

Hey guys! So it seems a few of you were having some issues with e-mail notifications not arriving, and we’ve had issues on our end as well. We’ve completely cleaned out our subscriber list now, so if you wouldn’t mind resubscribing to see if e-mails start coming again, that’d be great. Apologies for the kerfluffle, and hopefully this will have resolved our issue.

You can resubscribe via the widget just in our sidebar. Thanks!

10 Comments

  1. I’m not sure if the subscription worked or not. I got an email, but when i clicked to confirm my email, it took me to a page that said:

    Apologies, but the page you requested could not be found. Perhaps searching will help.

    If you arrived here after submitting a topic to the forums, please wait patiently for at least 24 hours before resubmitting, as your post is probably in the pending box.

    • That’s really strange; your subscription seems to have been confirmed just fine though! The only issue I can see is that the subscription confirmation page is a plugin-generated one, rather than a static one we set up. As such, I’ve made a quick page to confirm the subscription, so hopefully that resolves the issue?

  2. The same message for me too.

    • Is the same address you’ve used for this comment the one that you used to subscribe? If not, what address did you use? The other user’s confirmation seems to have gone through fine despite the page error, but I don’t see the address you’ve used on our subscriber list. If you’d like to try again, I’ve made some changes that hopefully resolve the issue.

  3. Thank you! It’s okay now!

  4. Subscription successful! =D

  5. I subscribed but I didn’t receive an email regarding today’s update.

    • Are you sure you completed the subscription properly? Your e-mail address (the one linked to this comment, at least) is not listed in our subscriber database. Did you receive a confirmation e-mail regarding your subscription? If not, you may have input the address wrong. Maybe try again?

      • Yeah, I got the confirmation email and activated it. But I just tried again, so maybe it will work this time, fingers crossed.

  6. only saw this now and subscribed again ^^
    I didn’t have any issues with the landing page, it did show a confirmation though I don’t remember the wording, it all looked normal to me though, so I guess the issue is solved now and I just wanted to confirm this :)

Leave a Comment